Jump to content

Welcome to We Got Served Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Moving To A 2-Drive Dell Optiplex Gx755 Usff

- - - - -

  • Please log in to reply
1 reply to this topic

#1
SJ_UnderWater

SJ_UnderWater

    Advanced Member

  • Members
  • PipPipPip
  • 376 posts
  • Gender:Male
  • Location:Boston, MA
Contributor
So, after getting really tired of my custom mini-ITX Atom WHS with its horribly loud fans that required auto-shutoff and auto-on for quiet, I seized on a gearxs.com deal for Core2 Duo GX755's ultra-small form factor at $139. It took me quite a while to get it working (a day), but it turned out to be mostly Dell stupidity and a couple issues I hadn't realized.

My old WHS had two drives, one 3.5" and one 2.5" (with the system partition, don't ask). With the new-ish Optiplex (which technically has only one SATA port), I was able to fit in both drives by using a D-type Modular Bay enclosure for SATA drives (this part I had figured out in advance, and both items arrived about the same time). So the idea was to put the secondary (3.5") drive in place of the 80GB the GX755 shipped with, and to take the cheap optical drive out of the modular bay and replace it with the 2.5" drive, while also taking the 1GB RAM from the old machine and putting it alongside the 1GB already in the GX755. The enclosure I got was partially corroded (!!), but managed to canabalize parts from the optical drive.

The facts: Dell missed several drivers though I searched by service tag, ATA/Legacy mode only allows booting from the primary/3.5" drive, and in AHCI mode it booted very slowly, suggesting some kind of SATA conflict, possibly caused by the SATA/IDE bridge in the bay enclosure. I managed to track down the Gigabit, video, Intel AMT SOL and HECI drivers, and finally got the most up-to-date SATA Controller driver directly from Intel, but AHCI still wouldnt boot successfully with both drives attached.

I have hopes that I will get AHCI to work, and at least the AHCI controller driver itself is in place if I need it. If anyone is curious, you can force an AHCI driver to install on an existing operating system by selecting the existing controller and "updating" the driver to AHCI by picking the specific INF file provided, just ok any warnings. Reboot immediately and Windows will use the right driver, preventing a blue screen.

The only issue left is that the BIOS won't let me choose the modular bay as the primary drive in ATA or Legacy mode, which means that I had to unhook the primary drive, wait for the error, then reattach it while the BIOS switched to the bay.

Does anyone know a relatively safe way to make a WHS's secondary drives bootable? If I can place a boot folder and use bootsect on the second drive, then I should be ok: the 3.5" will take control from the BIOS, then simply pass it on to the 2.5" drive with the system partition on it. Otherwise I'll buy one of those low-profile flash drives, put the boot files there, then configure it to pass boot to the 2.5" drive. I'd rather have a self-contained solution, but if it will keep me from opening the case every time I boot, I'll spend the $5.

Thanks in advance for any suggestions!


Upgrade to a WGS Supporter Account to remove this ad.

#2
SJ_UnderWater

SJ_UnderWater

    Advanced Member

  • Members
  • PipPipPip
  • 376 posts
  • Gender:Male
  • Location:Boston, MA
Contributor
so after much aggravation trying to get NTLDR to operate off of a flash drive, I found a very simple solution which works very well: syslinux. Basically, after downloading syslinux.exe, and running "syslinux -m -a <drive>:", I create a simple configuration file, syslinux.cfg, and copied the chainloader module, chain.c32 on to the drive. The configuration is:
DEFAULT WindowsHomeServer
LABEL WindowsHomeServer
SAY Loading Windows Home Server...
COM32 chain.c32
APPEND hd2 swap
Now I'm just looking for a cheap low-profile flash drive




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


Upgrade to a WGS Supporter Account to remove this ad.