Jump to content

Welcome to We Got Served Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Can't access Shared Folders

- - - - -

  • Please log in to reply
5 replies to this topic

#1
web ferret

web ferret

    Advanced Member

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Amsterdam, The Netherlands
  • Interests:WHS, Internet, Music (LOUD!!!), Electric Guitars and Ferrets!!!
I'm having trouble with my Shared Folders. After installing the Connector update I noticed a new icon on my desktop named 'Shared Folders'. In this folders are the standard subfolders visible that are on the WHS. At this time I didn't had a look at it because I was playing with the webinterface of WHS and my domain.

However, one day when I wanted to share a program that was on a cd I thought that it would be simple; just darg and drop the rootfolder from the cd into the webinterface and click on Upload. That didn't work, only the files in the rootfolder were uploaded but the subfolders were not.
I asked around here and I was told that installing the add-in 'WebFolders4WHS' would make it possible to upload folders with subfolders in it. So I installed the add-in, followed the instrauctions and everything has a green thick (Settings -> Add-ins -> WebFolder4WHS) and when I looked at the 'Share Folders' on my desktop I saw that there was a new folder added named 'WebFolder4WHSShare'. I thought that this would solve my problem but unfortunately, it's not.

Clicking on every folder gives me an error stating:

"\\Server\folder is not accessible. You do not have the permissions to access this networksource. Contact the administrator of the server to see if you have permission. Access denied."
(this is translated from my Dutch XP version).

There's is one exception, I can access the folder \\Server\Photos and even go into the subfolders and view files. This might be because I have the WHIIST add-in installed wich probably makes changes here or there that make this folder accessible.

My first question is how do I gain access to the Shared Folders? I have created an account for myself wich I use to login into the webinterface (works perfectly) and I have set all right on Full for all folders.

Secondly, how do I handle the 'WebFolders4WHSShare' folder? I was told by Spile to create a share under this folder but a) I really don't know how and B) what is exactly the function of this folder? When I want to open it I get an login screen. I have tried my own account but that doesn't work. I have tried Administrator with my WHS password, no luck.... I don't know what I must use!

I have tried to create a new folder (from within the Console) and with Full rights to my account but I get the same message when I try to open it via the 'Shared Folder' icon on my desktop.

Anybody who can help me out on this?


Upgrade to a WGS Supporter Account to remove this ad.

#2
web ferret

web ferret

    Advanced Member

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Amsterdam, The Netherlands
  • Interests:WHS, Internet, Music (LOUD!!!), Electric Guitars and Ferrets!!!
Hm... Nobody? :(

I have read the technical document from Microsoft on Shared Folders and User Accounts and what puzzles me is this paragraph:

"To access the share folders on your home server from a home computer, right-click the Windows Home Server tray icon, and then click Shared Folders. A Windows Explorer window will open displaying all of the shared folders on your home server. Though you can see all the shared folders, you will only be able to open the folders for which you have Read or Full permissions. If the user does not have permissions to the folder, an Access Denied message will be displayed. If a user needs permissions to a folder, their settings will have to be changed through the Windows Home Server Console.

Important

When users view shared folders from the Remote Access website, they will only be able to view the shared folders for which they have Read and Full permissions."

When I right-click the WHS console icon and select 'Shared Folders' I get an empty explorer window. Next to that; I have set the permissions on my account on FULL (in all Shared Folders and in the account).
The icon on my desktop named 'Shared Folders' (placed there after install off the Connector software) shows all the subfolders but as described before, trying to access them gives me an error concerning permission issues.

/edit: What I was thinking of this morning: on my client I do not have a user account, so I'm always logged in as Administrator. However, this is something my WHS doesn't know and on that fact it denies access to the shared folders. Simply because WHS does not know who is logged in on the client. Can someone confirm that my thoughts are right? Thus, to get access to the Shared Folders I need to log-in on the client with the same user credentials as they are known on the WHS (same username/password)?

This explains the fact that when I try to Remote from another client on the WHS to my own pc (also client on the WHS) that I get an popup to log-in with 'Administrator' already filled in as Username. Since I don't have a password activated for my own pc I guess I can just hit 'connect' (leave the password field blank)... But that doesn't work!

I am very confused right now....

#3
Guest_Drashna (WGS)_*

Guest_Drashna (WGS)_*
  • Guests
Before I proceed, I want to get a few things straight:
You are using the built-in Admin account on your computer, correct?
Its password does not match your servers.
And I'm tired right now, so I may have confused info.

I personally recommend never using the admin account on any computer, even a server if you can avoid it. Try setting up a new account, even if it does have admin priviledges, and make one on the server and make sure the credentials match exactly.

There are some account settings that prevent the admin account for working properly outside the server, and I wouldn't be surprised if this is one of them.

#4
web ferret

web ferret

    Advanced Member

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Amsterdam, The Netherlands
  • Interests:WHS, Internet, Music (LOUD!!!), Electric Guitars and Ferrets!!!

Before I proceed, I want to get a few things straight:
You are using the built-in Admin account on your computer, correct?

Yes. I'm the only user of my computer. Therefore there are no user accounts on this machine and when booting up I don't have to give a password.

Its password does not match your servers.

No, there is no password but even given this, it is not matching since WHS demands a password.

And I'm tired right now, so I may have confused info.

No hard feelings. I appreciate your help!

I personally recommend never using the admin account on any computer, even a server if you can avoid it. Try setting up a new account, even if it does have admin priviledges, and make one on the server and make sure the credentials match exactly.

Before I do this, let me reverse the question. Do you have a user account on your client and you must type in a password when you want to use your computer? And if so, is there a user account on your WHS with exactly the same username and password?

There are some account settings that prevent the admin account for working properly outside the server, and I wouldn't be surprised if this is one of them.

I wasn't aware of this fact. :angry:

#5
web ferret

web ferret

    Advanced Member

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Amsterdam, The Netherlands
  • Interests:WHS, Internet, Music (LOUD!!!), Electric Guitars and Ferrets!!!
I have answered my own question and learned a lot... B)

What have I done:

1. created an account on a client (pc A) with a password
2. created an account on the server with the same name an password as on the client
3. I switched users on the client and subsequently I had to login with the password
4. I used another client (pc X) to login (via [url="http://"https://webferrets.homeserver.com/remote)"%20as%20in%20WHS%20%3a%50"]https://xxxxx.homeserver.com/remote)[/url] on the server
5. I click 'Computers' and select client pc A and I give the same username and password as created in the first step
6. BINGO!!!!

Apparantly you MUST HAVE a user account other than the Administrator account on a client for Remote Access to work. As far as I can tell this is not documented by Microsoft in their technical briefing.

I tried other things:

- create a user named 'Administrator' on the server but that is not allowed
- I gave the Administrator account a password on the client (pc A) and tried again the steps 4 and 5 (see above) but that is not allowed either. I think the Adminstrator account is exactly what Drashna describes....

I'm happy that I have figured this out because ik kept me awake for a couple of days now.... :D

#6
Guest_Drashna (WGS)_*

Guest_Drashna (WGS)_*
  • Guests
On my personal computer, yes I have accounts with passwords. Do I have to input them every time? Heck no!

I use a built in feature to auto-log into my account, and I do the same thing with my media center. Saves a lot of headache!

Basically, set up an account on your server, and make a matching account on your computer. On your computer run "control userpasswords2" and uncheck "Users must enter a user name and password to use this computer". It will prompt you for a username and password when you click okay or apply. use the account your just set up. Now, every time the computer boots, it will automatically log into this account. No questions asked, or rather, no passwords prompted for!

And no, I don't think the administrator account thing is documented, but how many people use it? Also, if you ever add a user to the administrators group on the server, they will be locked out of the remote access website too. It's a "security" feature, I guess.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


Upgrade to a WGS Supporter Account to remove this ad.