Sign in to follow this  
Followers 0

Win 7 Client With Corrupted Wmc Connection

1 post in this topic

Posted · Report post

I have been on quite an odyssey for the past couple of months. It all started when a client running W7 ultimate produced unexpected error messages within WMC. This is the main client machine in our home which plays all of our media stored on WHSv1 with PP3. The only media WMC has trouble with is music. Pictures, movies, video (don't do TV yet) play fine and produce thumbnails etc.

The first error that had me panicking was the "file you are trying to play has become corrupted or cannot be found..." The thumbnails were present and I could navigate to tracks through WMC but just could not play them. In WMP, this was a non issue. So I deleted and then re-added within WMC the the mapped drive containing WMA 10 Professiona lossless tracks which are already libraries in W7. Same result - track(s) did not play. So I closed WMC, and deleted the WMP music database to through Windows explorer and had Media services rebuild it. Still hadn't any luck. I tried to re-install both the Console and Media connector through URL. This was unsuccessful. I went to another desktop and through console created another user account on WHS, and on the client. Still produced the same problem. I located the copies of WHS connector on the server itelf, put them on a thumb drive and did a manual install to the troublesome client. Still no luck. Next I deleted the rogue account and re-activated it. Nothing. After a few days of headscratching, no music and lurking on forums, inexplicably as the problem appeared the problem disappeared.

In WMC, the tracks are playable however not all from the library are present and any subsequent tracks I added to WHS only some showed up on the rogue client in the WMC library. On top of that, ALL of the music thumbnail disappeared. I was only able to navigate my music library through tagged info. In other words, just text appeared where the WMC thumbnails used to be. So if I navigated music by album artists, only the text from tagged info showed. (I am posting away from home right now, but I can upload a screen snapshot of the music library if this explanation is not clear.)

There are few other issues: back up is intermittent but, that's for another thread. I don't care if I don't have daily backups. The occasional one is fine becuase, I do not add much data to this machine and it seems to be in a corrupted state anyway. I went on to focus my troubleshooting on reproducing the thumbnails throu the eHome folder and LocalMLS folders on the client machine. This approach was misguided and a huge waste of time, I think. My suspicions are toward the Windows Media Center Connector. I get the "unexpected error" message which I tried to resolve by again lurking the forums. One poster suggested setting permissions in the TV folder on WHS so that Network Services has read/write (or full) permissions to resolve the unknown Media Center Connector issue. I am a little leary of going on another wild-goose chase.

Sorry for writing a book here. I have a hunch I might be reluctantly forced to re-install W7 but I wonder if anybody has a real clear sense on how to resolve this client connector issue. All the suggestions I read seem piecemeal and I cannot find an issue remotely similiar to mine.

Share this post

Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

Upgrade to a WGS Supporter Account to remove this ad.

  • Latest Posts

    • Decisions, Decisions. Keep Whs2011 Or Make The Leap To 8.1
      By wiretap · Posted
      I made the jump from WHS 2011 to Windows 8.1 x64 Pro w/ MCE.

      Old server:
      Intel i5 2500k Processor
      Gigabyte Z77X-D3H Motherboard
      8GB Corsair Dominator DDR3-1600
      90GB Corsair ForceGT SSD [OS Drive]
      20TB storage (FlexRAID∞ with 2-drive redundancy, all WD Green 1TB/2TB) 
      Ceton InfiniTV 4
      Rocketfish Case (modded to hold 20 hard drives)
      Highpoint DC-7280 Datacenter HBA
      Sans Digital TowerRAID 8-bay eSATA Enclosure
      Zalman 850w Heatpipe Cooled PSU
      WHS 2011 SP1

      New server:
      Norco RPC-4220 4U Case
      Corsair RM1000 Power Supply
      Supermicro X9SCM Motherboard
      Intel Xeon E3-1240 Processor
      Supertalent 16GB (4x4GB) DDR3-1333 ECC RAM
      Ceton InfiniTV4 PCI-e
      HDHomerun Connect (via network)
      3x IBM M1015 SAS Controllers flashed to IT Mode
      2x 250GB Samsung Evo 850 SSD's (Datastore and Backup Datastore)
      7x 4TB Western Digital SSHD's
      10x 2TB Western Digital Green HDD's
      1x 1TB Western Digital Passport for external backup images of OS
      5x SFF-8087 to SFF-8087 cables
      3x 120mm Arctic Cooling F12 PWM Fans
      2x 80mm Arctic Cooling F8 Rev.2 PWM Fans
      1x 92mm Arctic Cooling Alpine 11 Plus PWM CPU Fan
      ESXi 6.0
      VM1: Windows 8.1 x64 w/ MCE + Emby Server + Ubiquiti NVR + SnapRAID + Stablebit Drivepool and Scanner
      VM2: Windows Server 2012 R2 x64 + PRTG Network Monitor + Backup Management

      I went virtual, and I'm not looking back. It seems complicated when you first look at it, but it makes life so much easier.

      With the new server setup, I have everything pretty much fully automated, and it will send me alerts if there's an error or a scheduled task fails. Hard drives will alert me on a SMART error, SnapRAID sync/scrub send notifications when they complete successfully or fail, TV/movie recordings auto save and archive with Emby Server, Ubiquiti IPcam recordings and alerts get sent to my phone, etc. The new server also uses about 50w less power, as logged from my UPS, so that's good as well.

      ESXi is free, so I decided to give it a try. Deploying and managing VM's is very simple and I can even manage it from my phone via the VMware watchlist app. (you can even use remote desktop from it) I have it setup so my phone is connected to my pfSense router via OpenVPN, and ESXi alerts my phone if a VM has a problem.

      I stepped away from WHS 2011 since it has been phased out, and I went with Windows 8.1 x64 Pro w/ MCE since it has a little bit better support for my applications I use on the server side, and it also supports CableCARD in WMC natively. (using Cable Advisor DRM bypass for encrypted channels) It's much better than the ghetto rigged Ceton network tuner sharing loophole I had setup before.

      I'm also very happy with SnapRAID, since I was using FlexRAID before. It's much simpler, and I found FlexRAID buggy when I had to add/remove hard drives. I almost lost some of my data when a drive started to die and didn't alert me properly, then restoring it wasn't successful. (long story, as seen many times on FlexRAID forums)

      Hope this helps.
    • Raid Confusion
      By wiretap · Posted
      I use RAID 6 (SnapRAID + Stablebit Scanner) for my data array, then I use Backblaze to store the data offsite, and I also have a backup server just in case my whole main server shits the bed (i.e. power supply kills the hard disks). You're best off diversifying your data storage and keeping an off-site backup of your most important data.
    • Hi Folks
      By Siddy · Posted
      Just got the link to the forum after getting my eBooks, I have a Hp N54L server which is running WHS2011 on 1 SSD but just starting to build Win 10 into a server on a new SSD so now to read the book. Got stuck at the making the 16 gig free space and after a few reboots it showed it self. now to carry on lol.
    • Fujitsu 1900 Restore CDs
      By thechief55 · Posted
      Hello guys I am new to this forum I have just bought a used Scaleo 1900 without restore CDs. I have tried the links to Fujitsu Support in order to obtain lates restore CDs in this topic but to no success. Is it possible for someone to share an ISO image of the restore CDs for WHS 2008, I would be very grateful. Cheers
    • RAID 5 on the Motherboard and Intel Rapid Storage Technology Application
      By erlewis · Posted
      My guess is the Intel tool wants to manage it's own RAID.  I've seen so many posts over the years here and there complaining about hardware RAID that I tend to skip over the BIOS RAID options now.
  • Recently Browsing

    No registered users viewing this page.