Sign in to follow this  
Followers 0

Remote Access To Home Premium Hack

1 post in this topic

Posted · Report post

I thought I was upto the challenge of configuring things so I can remote access my Win7 Home Premium from WHS. Yes I know that Home does not have RDP, but that is easily resolved with this I am able to remote into my PC without issue from Win7 and XP PC's once I ran that. So that is working.

Next step is to trick WHS (SP2) to thinking that the PC is capable of RDP. Through some troubleshooting I was able to figure out that if I change the registry entry below WHS thinks it is capable. Granted this gets refreshed often a simple scheduled batch file will keep that setting.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Transport\Clients\the client entry----->from there I edit the TerminalServicesSupport key to "DS" versus "OS"

So now WHS shows that my PC is capable, but is states "Connection disabled"

One thing that I researched was if my RDP was configured correctly in the Home Premium PC. With this article, http://www.technize....-and-windows-7/ I confirmed my settings are correct. Additionally considering I am remote into it from both XP and Win7 this should be set correctly.

So this is where I am stuck and since I have commited myself to this hack I have to finish it. By all mean the time I have invested will far outway the $100 upgrade to Pro, but that is not why we do stuff like this.

Any suggestions?

Share this post

Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

Upgrade to a WGS Supporter Account to remove this ad.

  • Latest Posts

    • WHoSeBox - Use your WHS like dropbox
      By stigzler · Posted
      Hi folks. Just thought I'd share a little app I made. It lets you use your WHS like dropbox - with public shares + link grabbing from explorer. I'm a hobby coder - so don't expect watertight - but think it's working OK - any probs just let me know. Check it here:
    • Questions on Planning and Preparing for a N54L
      By darkarn · Posted
      Thanks for your reply! Ah, that issue. I was thinking of using a modded BIOS though, which HP wont support lol, but the network card not working is news to me. Besides, I am strongly considering to pay a bit more and go for a Gen8 instead.
    • Shares - A Nightmare!
      By Hyde · Posted
      Have shut down the RDP session and re-connected.  Using the host machine's name I still get the message back that the Server isn't switched on, not my network, etc. etc.  Tried again with the IP address and once again I get the warning that the certificate isn't from a trusted source, but at least I can still get an RDP session and the Sharing dialog box is still churning some 20 minutes since I kicked it off (for the 3rd time at least today).  So, would be nice to know why I have this certificate error too???  and how to fix it ;-)
    • Questions on Planning and Preparing for a N54L
      By Guest · Posted
      Don't.. HP has poor support, and there's lots of compatibility issues with N54l.

      Flashing the bios requires permission from HP before you can even download it, luckily i found another download link, but even after updating the bios, the network card still does not work with Windows.
    • Shares - A Nightmare!
      By Hyde · Posted
      Also having issues with RDP.  But having changed the client connection from using the PC's name to it's static IP I got an error message about the certificate not being from a trusted source.  Ignoring the warning and continuing to connect allowed me to gain a connection from my laptop and then typing "certificate" into the Settings search box got me a tool that allowed me to drag n drop the RDP certificate into the Trusted Root folder.  I'm hoping that'll help with all my connections now but I don't know and don't currently want to shut this RDP session down until performing a few tasks whilst I still can. I have now managed to share out my Software folder on the Server.  Yippee!  But the Music folder sharing is still churning away.  I can only guess it's down to the fact that there are 544 folders & 5265 files???
  • Recently Browsing

    No registered users viewing this page.