Hp Ex48X Lights Management Driver For Whs 2011

482 posts in this topic

Posted · Report post

btn_donateCC_LG.gif

Thank for your support.

Updated 2011-09-27

VERSION 1.0.6 RELEASED

  • Please uninstall any previous version before installation.
  • You also need to install the Intel RST driver that replaces the standard SATA driver. Check the readme.txt for more information. If you do not install the Intel RST driver the disk lights will not work.
  • Read the readme.txt file to understand the light states and how to modify them.

    Dowload link: HpMssServiceSetup_v1.0.6

    What's new
    • Support for Acer H341 and H342. Please do some tests and report any issues.
    • Disk light status can be changed in the configuration file. This is particularly useful for users of DrivePool, DriveBender, RAID arrays and drives without shares when the user does not want a blinking aqua LED.
    • Removed some uncessary DLL's from the setup.

    Tested compatible hardware

    HP: EX48x, EX49x, X510, X310, X311, X312

    Acer: H340, H341, H342

    Lenovo: D400

    Not compatible

    HP: EX47x (AMD based hardware)

    Known limitations and FAQ

    Blinking disk LED

    This is normal under the following circumstances:

    [*]the disk does not have any shares on it (WHS shares created in the Dashboard)

    [*]the disk is not assigned as a backup disk

    [*]the disk is mirrored

    [*]the disk is assigned to Stablebit DrivePool, DriveBender or a RAID array

    Workaround: edit the configuration file "C:\Program Files\HP MediaSmart Server\HpMssService.exe.config" to use a fixed Aqua LED. The instructions are in the file.

    Windows OS compatibility

    Only Windows Home Server 2011 has been tested. Should also be compatible with Windows Small Business Server 2011 Essentials and Windows Storage Server 2008 R2 Essentials.

    GPT partitioned disks not propely detected

    There is an issue in the WMI Win32_DiskDrive class, GPT disks do not have a signature and this is the only way I can match a disk status change with a physical disk. A solution should be found for the next version.

    To come...

    The next version will be based on the Microsoft Virtual Disk Service (VDS) which recognizes RAID arrays and GPT partitions. The other advantage is that it would also be compatible with vanilla Windows Server 2008 R1/R2 and probably the future Windows 8 Server.

    The next version should also be hardware agnostic by renaming the service and DLLs since Acer and Lenovo hardware are supported.

    Health support should also come later. WHS health notifications will be supported and I also plan on monitoring fan, temperatures and voltages.

    Make it a "real" add-in.

13 people like this

Share this post


Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

Posted · Report post

I would be very interested in such a driver!

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Alexander,

I'm happy to see that at least one person is interested in this driver! I will not make the driver public unless I see more people are interested. I will send you a message to discuss how I can send you the driver when it is ready.

For now, I have a working driver on my machine but:

1) I need to finish the installer, more specifically the driver installation portion of the installer.

2) I have to obtain a signing code certificate for my company in order to sign the driver, otherwise it will not load.

I will keep you informed when all is ready.

Louis

Share this post


Link to post
Share on other sites

Posted · Report post

I would also be interested in such a driver if one is available.

Share this post


Link to post
Share on other sites

Posted · Report post

Here's the latest news. I now have a signing certificate and the driver loads without having to put the server in test mode. Last thing I have to finish for the beta release is the installer. I hope to finish this next week-end. I will contact both of you to send you the driver when ready.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Louis

I think this will definitely be popular - over time, an increasing number of people will upgrade their MediaSmart Servers. Bear in mind, the majority of owners interested in doing so can't actually buy the software yet...

Good luck with it - drop me a PM when it's ready and we'll give it a plug on the front page.

Terry

Share this post


Link to post
Share on other sites

Posted · Report post

I'd too be very interested. I have a EX475 running WHS 2011 and I'd really like to cooperate with you to make it work on this model as well.

Share this post


Link to post
Share on other sites

Posted · Report post

Here's the latest update. I worked a lot this week-end on this application. I now have a working setup and I am doing some testing to clear out the issues I find. I had a lot of work to get this working properly after a resume from sleep. I am almost finished, be patient.

Concerning the request from paaland, getting this to work on EX47x, I'm afraid this will be difficult. The low level code is based on the Linux code from Chris Byrne which can be found here https://bitbucket.or...erverd/overview. I did not do the reverse engineering myself. I could probably get this to work on an Acer EasyStore H340 with this code, but for other hardware I do not have any knowledge on how to access the registers to handle the LEDs. Even the EX49x does not use the same chip for I/O though it has the same Intel ICH9, so there is a small chance that this code could work with no or little work, but then again not having the hardware I cannot do this. There is no guarantee that the LEDs are connected to the same registers as the EX48x. Concerning the EX47x it would be even harder as it is not Intel based.

The only chance to get this working on EX47x and EX49x (and maybe other) hardware is if someone can give me information on how to access the LEDs. There might be some information on the Internet, especially developers who tried to get this working under Linux.

For beta testing, I would like to distribute the application to the 4 people above who replied positive to the driver if they are interested. Please send me a private message with your e-mail address, I will send you the driver probably by the end of the week or beginning of next week. If you accept I will need your feedback to know if the driver works well. I will then let Terry know the driver is ready for public distribution.

Louis

Share this post


Link to post
Share on other sites

Posted · Report post

Hi There,

I have an acer H341 and would be more than appreciative if you could release a led driver for that model. I know quite a few people have been looking for this. I do some application programming, but have not done any driver coding, but if you need my help I would be more than willing. Also have a technet sub. so if you need any help there, just let me know!

Here's the latest update. I worked a lot this week-end on this application. I now have a working setup and I am doing some testing to clear out the issues I find. I had a lot of work to get this working properly after a resume from sleep. I am almost finished, be patient.

Concerning the request from paaland, getting this to work on EX47x, I'm afraid this will be difficult. The low level code is based on the Linux code from Chris Byrne which can be found here https://bitbucket.or...erverd/overview. I did not do the reverse engineering myself. I could probably get this to work on an Acer EasyStore H340 with this code, but for other hardware I do not have any knowledge on how to access the registers to handle the LEDs. Even the EX49x does not use the same chip for I/O though it has the same Intel ICH9, so there is a small chance that this code could work with no or little work, but then again not having the hardware I cannot do this. There is no guarantee that the LEDs are connected to the same registers as the EX48x. Concerning the EX47x it would be even harder as it is not Intel based.

The only chance to get this working on EX47x and EX49x (and maybe other) hardware is if someone can give me information on how to access the LEDs. There might be some information on the Internet, especially developers who tried to get this working under Linux.

For beta testing, I would like to distribute the application to the 4 people above who replied positive to the driver if they are interested. Please send me a private message with your e-mail address, I will send you the driver probably by the end of the week or beginning of next week. If you accept I will need your feedback to know if the driver works well. I will then let Terry know the driver is ready for public distribution.

Louis

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all,

I would like to know if there are people out there interested in a lights driver for their HP EX85x server under WHS 2011. As some of you know, when upgrading your EX48x server to WHS 2011 your HDD lights stay off and the system light blinks all the time. I am currently writing a driver to replicate the LED management as it was with the original HP software.

I would like to know if other users are interseted in this driver to see if I should make it publicly available. One of the issues I will have will be to get a signing certificate because you cannot install unsigned drivers on WHS 2011, unless putting the server in a special test mode which is what I am doing at the moment for my tests.

Louis

Share this post


Link to post
Share on other sites

Posted · Report post

I would LOVE to see my light work with WHS 2011 !!

Share this post


Link to post
Share on other sites

Posted · Report post

+1 The lights would be a great add! I have an EX495, will it work with mine?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Louis, I have an Acer EasyStore H340 and I'm interested into trying your driver. There is some infos here and reverse engineering here. I hope this can help you. Just let me know if I can help you with something.

Thanks,

Claude

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Louis, I have an Acer EasyStore H340 and I'm interested into trying your driver. There is some infos here and reverse engineering here. I hope this can help you. Just let me know if I can help you with something.

Thanks,

Claude

Hello Claude,

I might be able to get this working on an Acer H340 because the LED driver code I found has the code to manage the H340. As soon as the EX48x version is validated I will try to send you a version for test.

Louis

Share this post


Link to post
Share on other sites

Posted · Report post

I now have a final version which I proposed to some people for testing. So far only one person told me they tried it and the first results are not positive. The health management light stopped blinking but the HD LEDs are not working. I am waiting from this person the log file in order to figure out why it works on my server but not on his.

I would appreciate if the other people to which I send the link to download the application could let me know their results. I can only get this to work with the help of testers!

Share this post


Link to post
Share on other sites

Posted · Report post

Hello Claude,

I might be able to get this working on an Acer H340 because the LED driver code I found has the code to manage the H340. As soon as the EX48x version is validated I will try to send you a version for test.

Louis

Thank you, I really appreciate your work! If you need any help in the meantime, just PM me.

Claude

Share this post


Link to post
Share on other sites

Posted · Report post

I'm interested. I'm planning on migrating my EX495 to WHS2011 but haven't yet.

Share this post


Link to post
Share on other sites

Posted · Report post

I am totally interested in getting the Acer H340 lights working as I now have WHS 2011 running on it...

Share this post


Link to post
Share on other sites

Posted · Report post

I'd also be interested in the drivers for an HP Mediasmartserver ex490 - I'd even pay for them!!

Share this post


Link to post
Share on other sites

Posted · Report post

I see some requests for hardware other than EX48x. Here is the situation:

Acer H340: probably yes. The LED driver code is based on this https://bitbucket.or...erverd/overview and the H340 code is there. Once the EX48x version has been certified I will try to add the H340. But not having the hardware I will need a tester.

EX47x: without more information it is impossible. The hardware is totally different.

EX49x: the hardware is similar to EX48x but I don't know if it will work. If the LED mappings are different it will not work. Not having the hardware it is impossible for me to figure it out.

Acer H341: I think the hardware is similar to H340 but I am not sure. And even if similar I have the same issues as EX49x.

Once the EX48x has been tested and validated I will let one EX49x user try it AT THEIR OWN RISK. This driver accesses hardware I/O ports so there is a small chance of bricking the server or permanently modifying a function or feature.

Once the H340 version is tested and validated I will do the same for H341 as for EX49x.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all,

I would like to know if there are people out there interested in a lights driver for their HP EX85x server under WHS 2011. As some of you know, when upgrading your EX48x server to WHS 2011 your HDD lights stay off and the system light blinks all the time. I am currently writing a driver to replicate the LED management as it was with the original HP software.

I would like to know if other users are interseted in this driver to see if I should make it publicly available. One of the issues I will have will be to get a signing certificate because you cannot install unsigned drivers on WHS 2011, unless putting the server in a special test mode which is what I am doing at the moment for my tests.

Louis

I have an HP EX510 running Windows Server 2008 R2.

I have been looking for a solution to fix LED management and am definitely interested in trying out the driver.

Share this post


Link to post
Share on other sites

Posted · Report post

Also interested and also willing to pay a small fee for the LED driver for the ex49x series...i am sure many people would be.....

Share this post


Link to post
Share on other sites

Posted · Report post

I would like to know if other users are interseted in this driver to see if I should make it publicly available. One of the issues I will have will be to get a signing certificate because you cannot install unsigned drivers on WHS 2011, unless putting the server in a special test mode which is what I am doing at the moment for my tests.

Louis

Hey Louis, I guess lot of people are interested in that project. How is it going? Any news from your beta testers, we are all waiting to try it out. Please give some update or some people will think you stopped that nice project.

Claude

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now



Upgrade to a WGS Supporter Account to remove this ad.



  • Latest Posts

    • WD DS5100 -- Setup questions
      By fasttimes · Posted
      I found under the Storage Tab / Hard Drives an option which let me add the two unallocaed drives. When I click on Manage, it tells me I have: Two-way mirror 16.0TB using 2.50 GB pool capacity A little poking around and it seems I have a pool of 3.6 TB and a capacity of 16 TB.  I'm a little confused as to what those are.  Maybe I missed a sticky on the forums here. When I look at explorer, it shows that I have 16TB on my (new) D drive.  How can that be if I only have a 4TB box?
    • WD DS5100 -- Setup questions
      By fasttimes · Posted
      I just got my WD DS5100 today (4TB) http://store.westerndigital.com/store/wdus/en_US/DisplayProductDetailsPage/ThemeID.30663100/categoryID.68246000/subCategory.68246200/parid.59193300/catid.68245900/WD_Sentinel_DS5100 I went through the initial boot and setup, however I only see the OS drive.  If I go to disk manager, I see two other unallocated drives.  What do I have to do to bring these guys online?  Do I have to do that from disk manager?  I would think (hope) that the regular dashboard would do this for me.  What drive options are available for Essentials (extender, mirroring, etc)?   I think that decision needs to be made before I do anything else. Is there a "getting started" guide?  I'm coming from WHS v1, and wanted to know what disk options are available.  My initial goal is to get my various computers automatically backing up like they did for WHS.  Is this still called the "connector" for Essentials?  I'd still like to find a tour of what features are available.  I'm sure there is a lot of functionality I will never use, but I'd like to at least know it exists. Thanks!      
    • H340 Motherboard Swap
      By mrhappy002 · Posted
      Hey guys! I'm hoping you can help me out. I bought a used (but working) mini-ITX Intel DQ45EK motherboard on which I repurposed a CPU I had (Intel Core 2 Duo E6420 @ 2.13GHz) and 4Gb of RAM. I've tested my soldering and I read good voltages. The problem is the following: the minute I plug the power cable on the H340, both the CPU and system fan spin and stop, spin and stop, continuously. I do not get a beep or nothing. I have unplugged and reconnected the PSU but still no go. Also, I tried starting without connecting the 4-pin yellow and black PSU cable and this makes the fans spin continusouly. No stop and go...?! I will try to see if the problem is the PSU (with another one I have somewhere) but it should be working. Could my setup be taking too much power for the CPU to be able to start up? I dont know... Any help would be appreciated. I also tried removing the RAM, etc.
    • Decisions, Decisions. Keep Whs2011 Or Make The Leap To 8.1
      By wiretap · Posted
      I made the jump from WHS 2011 to Windows 8.1 x64 Pro w/ MCE.

      Old server:
      Intel i5 2500k Processor
      Gigabyte Z77X-D3H Motherboard
      8GB Corsair Dominator DDR3-1600
      90GB Corsair ForceGT SSD [OS Drive]
      20TB storage (FlexRAID∞ with 2-drive redundancy, all WD Green 1TB/2TB) 
      Ceton InfiniTV 4
      Rocketfish Case (modded to hold 20 hard drives)
      Highpoint DC-7280 Datacenter HBA
      Sans Digital TowerRAID 8-bay eSATA Enclosure
      Zalman 850w Heatpipe Cooled PSU
      WHS 2011 SP1

      New server:
      Norco RPC-4220 4U Case
      Corsair RM1000 Power Supply
      Supermicro X9SCM Motherboard
      Intel Xeon E3-1240 Processor
      Supertalent 16GB (4x4GB) DDR3-1333 ECC RAM
      Ceton InfiniTV4 PCI-e
      HDHomerun Connect (via network)
      3x IBM M1015 SAS Controllers flashed to IT Mode
      2x 250GB Samsung Evo 850 SSD's (Datastore and Backup Datastore)
      7x 4TB Western Digital SSHD's
      10x 2TB Western Digital Green HDD's
      1x 1TB Western Digital Passport for external backup images of OS
      5x SFF-8087 to SFF-8087 cables
      3x 120mm Arctic Cooling F12 PWM Fans
      2x 80mm Arctic Cooling F8 Rev.2 PWM Fans
      1x 92mm Arctic Cooling Alpine 11 Plus PWM CPU Fan
      ESXi 6.0
      VM1: Windows 8.1 x64 w/ MCE + Emby Server + Ubiquiti NVR + SnapRAID + Stablebit Drivepool and Scanner
      VM2: Windows Server 2012 R2 x64 + PRTG Network Monitor + Backup Management

      I went virtual, and I'm not looking back. It seems complicated when you first look at it, but it makes life so much easier.

      With the new server setup, I have everything pretty much fully automated, and it will send me alerts if there's an error or a scheduled task fails. Hard drives will alert me on a SMART error, SnapRAID sync/scrub send notifications when they complete successfully or fail, TV/movie recordings auto save and archive with Emby Server, Ubiquiti IPcam recordings and alerts get sent to my phone, etc. The new server also uses about 50w less power, as logged from my UPS, so that's good as well.

      ESXi is free, so I decided to give it a try. Deploying and managing VM's is very simple and I can even manage it from my phone via the VMware watchlist app. (you can even use remote desktop from it) I have it setup so my phone is connected to my pfSense router via OpenVPN, and ESXi alerts my phone if a VM has a problem.

      I stepped away from WHS 2011 since it has been phased out, and I went with Windows 8.1 x64 Pro w/ MCE since it has a little bit better support for my applications I use on the server side, and it also supports CableCARD in WMC natively. (using Cable Advisor DRM bypass for encrypted channels) It's much better than the ghetto rigged Ceton network tuner sharing loophole I had setup before.

      I'm also very happy with SnapRAID, since I was using FlexRAID before. It's much simpler, and I found FlexRAID buggy when I had to add/remove hard drives. I almost lost some of my data when a drive started to die and didn't alert me properly, then restoring it wasn't successful. (long story, as seen many times on FlexRAID forums)

      Hope this helps.
    • Raid Confusion
      By wiretap · Posted
      I use RAID 6 (SnapRAID + Stablebit Scanner) for my data array, then I use Backblaze to store the data offsite, and I also have a backup server just in case my whole main server shits the bed (i.e. power supply kills the hard disks). You're best off diversifying your data storage and keeping an off-site backup of your most important data.
  • Recently Browsing

    No registered users viewing this page.