psionguy

Squeezebox Duet Software Install On Whs 11- Hp Micro Server

20 posts in this topic

I am just getting into my new HP Micro server running WHS 11. I have managed to install my first addon (asoft auto exit) via my client PC and all went well.

I am now trying to install Squeezebox software vs. 7.70-33614 for my Duet setup. When I try and install from my PC I get the message this software is for WHS only. Looking at the instructions from Logitech it states the file should be on the shared folder Software/addon but there is no folder of this name. So I created a folder called addon on one of my micro server drives and copied the msi file there, when I try and run this I still get the same message.

Should I place the folder on the server C drive, or do I need to install directly on my server instead of my client PC?

Any guidance would be greatly appreciated.

Share this post


Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

Which version of the software are you trying to add?

The WHS squeezecentre addon is for WHS1 only. It will not work on WHS 2011.

The standard dektop software however works on WHS 2011. You do not get to access it via the Dashboard, but you can access perfectly via a web browser.

I have it installed and works just fine.

Share this post


Link to post
Share on other sites

Which version of the software are you trying to add?

The WHS squeezecentre addon is for WHS1 only. It will not work on WHS 2011.

The standard dektop software however works on WHS 2011. You do not get to access it via the Dashboard, but you can access perfectly via a web browser.

I have it installed and works just fine.

Ian

As I am very new to this setup could you let me know how to install the standard setup on my WHS 11. I Have downloaded the standard 7.70 Vs, I assume the only way you can install on there server is direct, as any other way will just install on your PC, is this correct?

I am hoping that I can run this server without the need of my PC being on, is that possible?

Thanks

Share this post


Link to post
Share on other sites

You are correct on both counts.

If you have a screen and keyboard on your WHS then install that way, if not then Remote into the WHS and then install.

It does indeed run on the server without the need for your PC to be on. You may need the PC to login to the web interface, but you can also log in to this on the server if you have screen and keyboard! You don't need to use the web interface as you can control things with the Duet (well I'm assuming so, I actually have the older Squeezebox)

When you have installed - go into the control panel on the server and choose the startup option you want. I have mine set as Automatically run at susyem startup.

The only issue I have encountered was when streaming live radio frem the BBC. I have Peerblock running in the background of my WHS and I had to open the relevant ports for the BBC to stream.

Share this post


Link to post
Share on other sites

You are correct on both counts.

If you have a screen and keyboard on your WHS then install that way, if not then Remote into the WHS and then install.

It does indeed run on the server without the need for your PC to be on. You may need the PC to login to the web interface, but you can also log in to this on the server if you have screen and keyboard! You don't need to use the web interface as you can control things with the Duet (well I'm assuming so, I actually have the older Squeezebox)

When you have installed - go into the control panel on the server and choose the startup option you want. I have mine set as Automatically run at susyem startup.

The only issue I have encountered was when streaming live radio frem the BBC. I have Peerblock running in the background of my WHS and I had to open the relevant ports for the BBC to stream.

Ian thanks for your help much appreciated.

I have now got Sqeezebox server running and can access via my client PC, but to get it to work I have to now logon onto my server and re-start logitech media server. As I normally do not have it connected to a monitor, it looks like I will have to keep it connected in the future.

I have been using asoft auto exit, which enables me to re-boot the server from my client PC, and this makes the server available to everything except Logitech media.

Hope I am making sense, so if I am correct is there any way around having to logon onto the server every time I do a re-boot?

Share this post


Link to post
Share on other sites

When you have installed - go into the control panel on the server and choose the startup option you want. I have mine set as Automatically run at susyem startup.

Should do it for you

Share this post


Link to post
Share on other sites
When you have installed - go into the control panel on the server and choose the startup option you want. I have mine set as Automatically run at susyem startup. Should do it for you

Ian

I am struggling with this for some reason. If I boot my server I get the screen alt ctrl del to logon, when I logon I then have to click on Logitech sever icon and load the software, for it to be recognised by my streamers I have to stop the server and the re-start and only then is it recognised on my other devices. If I then logoff of the server, all my streamers still see my hpserver and I can access my files, but the Logitech server is no longer seen.

So I have to make the assumption that I have to manually log on to my hpserver (or can this be automated if yes how?) and then load the squeezebox and stop and start this server even though I have selected auto start on this software. It is a shame that there is not an addon for WHS 11.

Share this post


Link to post
Share on other sites

How odd.

Mine auto logons at startup having changed the setting I mention above.

You can start any program without having to logon by using task scheduler. I guess you could do this but I would be more interested why it isn't working as it should.

Did you log on as administrator when you laded squeezecentre?

Share this post


Link to post
Share on other sites

How odd.

Mine auto logons at startup having changed the setting I mention above.

You can start any program without having to logon by using task scheduler. I guess you could do this but I would be more interested why it isn't working as it should.

Did you log on as administrator when you laded squeezecentre?

Yes I did log on as administrator. When you setup auto logon at start up, was this on the HPserver or Logitech software. I can see the option for auto log on the Logitech, but cannot find this option on WHS 11; perhaps this is where I am going wrong.

Ray

Share this post


Link to post
Share on other sites

No - in the squeezebox server.

Share this post


Link to post
Share on other sites

Or maybe not.

You got me wondering - there was an update recentlly, which I installed and didn't really think about.

However I've just had a quick play and it seems you are right. The old version did work on startup, not needing to login but this seems not to work in the updated version.

I'm out and about for the rest of the week but will experiment some more when I get back in.

Share this post


Link to post
Share on other sites

I foud time - the update had wiped out my settings.

When you checked the run at startup box, did you add a username and password with admin priveledges in the boxes below? That was what got me with the update!

Share this post


Link to post
Share on other sites

I foud time - the update had wiped out my settings.

When you checked the run at startup box, did you add a username and password with admin priveledges in the boxes below? That was what got me with the update!

When I open Logitech Media Server Control Panel ther is a drop down arrow with 3 options, I have selected Automatically run at system start. Underneath there is 2 blank spaces for username and password, you can only add to this is you have selected automatic start. I them enter my logon details which is my email address and then my password, I theh hit apply and OK. When I log off and then re start my password details are not in the boxes and I don't understand why.

When you mention admin priveledges, are you reffering to when I first run the squeezebox exe, as I can't remember, but I would have used my squeezebox logon when it was installed. There is no sign of admin priveledges in the server control panel now, could you confirm it is the same on yours.

Do you think I should remove and reload the squeezebox software, and be carefull about ticking all the right boxes?

Share this post


Link to post
Share on other sites

The user and password need to be the same as a logon to WHS that has admin priveledges

1 person likes this

Share this post


Link to post
Share on other sites

The user and password need to be the same as a logon to WHS that has admin priveledges

Ian many thanks, all now sorted and working 100%.

You have been a great help to me, much appresiated.

Share this post


Link to post
Share on other sites

It would be great if psionguy would post back on what detail finally got it working, as there will probably be others with the same question who find this via Google and then wonder what the answer was. :mellow:

Share this post


Link to post
Share on other sites

I think the answer is my last post to him.

Share this post


Link to post
Share on other sites

The standard dektop software however works on WHS 2011. You do not get to access it via the Dashboard, ...

 

I get to CrashPlan and Microsoft Security Essentials clients installed on WHS 2011 by putting shortcuts on the desktop. I get to those through Advanced Admin Console, and navigate to the Desktop using Explorer. Works like a charm for me. Perhaps it will work for Squeezebox desktop?

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now



Upgrade to a WGS Supporter Account to remove this ad.



  • Posts

    • I've got the same problem and used that utility C:\Program Files\Windows Home Server\WHSOOBE.exe. It continue the server installation from entering server name, password, password hint and etc...
    • I used the database repair and clean up that are part of WHS program under settings (2nd photo). I have placed an order for two 2tb external hard drive to connect to my system so I can select to remove the drives one at a time from the system to do a reformat on each to check them. They will be here in a week if that does not work I plan to delete all the existing backups and starting with a new backup of the 2 computers connected to it. It will probably take a while as my current setup (1st photo) is the original 500 gig boot drive that original came with it and 3 internal 2 tb hard drives  plus a 4 slot esata system each with a 2 tb drive and 2 usb 2 tb plus the 2 I am going to be adding so the current total backup capacity is 16.83 Tb with me adding another 4tb. So it may be a while before I can get through all the drives. Will report back how I make out once I am done. If anyone knows a quicker way feel free to let me know. 
    • Hi guys. Resurrecting this thread, as we're coming up on 3 years...and well, life got in the way and I never managed to do any upgrades. I guess the good news is my HP LX195 is still humming as-is. I've since migrated most of my family's data (wife, 5 kids) to their OneDrive accounts, and cross-shared their drives with each other so it's a virtual home network out in the cloud. Not the fastest performance but it beats worrying about backups. Essentially now the only thing I rely on the WHS v1 box for is its Whiist add-in. We still to this day reference our old FrontPage-created family website with pages of the kids' growing up. I'm not into Farcebook or social networking so don't plan to migrate that anywhere anytime soon. QUESTION then - I was thinking of using these holiday discounts to buy a small workstation (again) to do some of the "faster" type of local filesharing we need (photo editing, etc.) But - is there any current Whiist-like solution (basic webserver tools) available in Windows 10, or even Windows 2012/2016 Essentials that I can migrate the directories to? Advice appreciated. Thanks and glad to be back... ENV  
    • What do I need to know? I'm just so tired of all the stupid Windows irritating nonsense and want something that just works without my constant attention.  I currently run WSE2012R2 + Stablebit Drivepool with 3x4TB drives (WD Reds) and external backups on a Supermicro MB w/Core i3 with 20 GB Ram. OS is on a 128 SSD.  I run the drives on a SCSI card and it just decided to not boot off theSSD the other day, so I connected it back to the MB port. I only have one laptop, one desktop that get backed up and the DT one is always failing. I uninstall the connector, reinstall, blah, blah , blah... it  works for a while and then fails again. This makes the Client backups worthless.   I have some gremlin the hardware that causes it to reboot all the damn time, or maybes its SW, dunno.  I thought it was heat and confirmed all fans work, drives are not overheating, no smart errors.  Might be one of my external eSata boxes, not sure.  My server hardware is from 2011, so getting a bit old, but still works. WSE dashboard crashes all the time. I'm tired of looking at logs to fix it.  I want/need NAS (Synologoy) to work with Plex via a Roku.  I also use a Squeezebox (2), but they are failing and I am about to give up on them for music streaming.  I also use Chromecast in the house.  So I guess Plex for both music and movies/videos is the plan.   Also, want the NAS to work with security cameras.  Which Synology Do I get?  I think I want a 4 drive minimum unit. Do I need a 'Play' one, or not?  What else? I have plenty of hard drives. I can budget $1K if needed, but half that sounds better to me.        
    • so is there anything listed anywhere for addins? I just cant find anything on google.
  • Popular Contributors

    Nobody has received reputation this week.