SJ_UnderWater

Moving To A 2-Drive Dell Optiplex Gx755 Usff

2 posts in this topic

So, after getting really tired of my custom mini-ITX Atom WHS with its horribly loud fans that required auto-shutoff and auto-on for quiet, I seized on a gearxs.com deal for Core2 Duo GX755's ultra-small form factor at $139. It took me quite a while to get it working (a day), but it turned out to be mostly Dell stupidity and a couple issues I hadn't realized.

My old WHS had two drives, one 3.5" and one 2.5" (with the system partition, don't ask). With the new-ish Optiplex (which technically has only one SATA port), I was able to fit in both drives by using a D-type Modular Bay enclosure for SATA drives (this part I had figured out in advance, and both items arrived about the same time). So the idea was to put the secondary (3.5") drive in place of the 80GB the GX755 shipped with, and to take the cheap optical drive out of the modular bay and replace it with the 2.5" drive, while also taking the 1GB RAM from the old machine and putting it alongside the 1GB already in the GX755. The enclosure I got was partially corroded (!!), but managed to canabalize parts from the optical drive.

The facts: Dell missed several drivers though I searched by service tag, ATA/Legacy mode only allows booting from the primary/3.5" drive, and in AHCI mode it booted very slowly, suggesting some kind of SATA conflict, possibly caused by the SATA/IDE bridge in the bay enclosure. I managed to track down the Gigabit, video, Intel AMT SOL and HECI drivers, and finally got the most up-to-date SATA Controller driver directly from Intel, but AHCI still wouldnt boot successfully with both drives attached.

I have hopes that I will get AHCI to work, and at least the AHCI controller driver itself is in place if I need it. If anyone is curious, you can force an AHCI driver to install on an existing operating system by selecting the existing controller and "updating" the driver to AHCI by picking the specific INF file provided, just ok any warnings. Reboot immediately and Windows will use the right driver, preventing a blue screen.

The only issue left is that the BIOS won't let me choose the modular bay as the primary drive in ATA or Legacy mode, which means that I had to unhook the primary drive, wait for the error, then reattach it while the BIOS switched to the bay.

Does anyone know a relatively safe way to make a WHS's secondary drives bootable? If I can place a boot folder and use bootsect on the second drive, then I should be ok: the 3.5" will take control from the BIOS, then simply pass it on to the 2.5" drive with the system partition on it. Otherwise I'll buy one of those low-profile flash drives, put the boot files there, then configure it to pass boot to the 2.5" drive. I'd rather have a self-contained solution, but if it will keep me from opening the case every time I boot, I'll spend the $5.

Thanks in advance for any suggestions!

Share this post


Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

so after much aggravation trying to get NTLDR to operate off of a flash drive, I found a very simple solution which works very well: syslinux. Basically, after downloading syslinux.exe, and running "syslinux -m -a <drive>:", I create a simple configuration file, syslinux.cfg, and copied the chainloader module, chain.c32 on to the drive. The configuration is:


DEFAULT WindowsHomeServer

LABEL WindowsHomeServer

SAY Loading Windows Home Server...

COM32 chain.c32

APPEND hd2 swap

Now I'm just looking for a cheap low-profile flash drive

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now



Upgrade to a WGS Supporter Account to remove this ad.



  • Posts

    • So I currently have Windows Server 2012 Essentials (running in a Hyper-V VM) and am thinking about migrating to a Windows 10 server. I have 12 disks or so on the server all configured via Storage spaces. Can I simply connect these disks up to a Windows 10 install and have all the files appear? From what I have read the storage space info is all on the disks and it should work, but has anyone here actually tried it and succeeded. I have 10+ TB of data and the easiest way to get it to the new server would be to just connect the disks up.   Thanks, -Bill
    • Did you try CC cleaner or a disk clean up program? It seems to me that old files merged or not are still existing, do you have external storage that you could export the known good files to while you reformat and clean the 6TB?
    • Hello Is it possible to clone an external HDD containing the server backup to another external HDD? The external HDD doesn't have a drive letter, so how can I clone the drive?  I have two external drives in a Dual Dockingstation (2 drives), which has a button to clone from A to B, but I don't trust that solution too much..
    • I have a whs 2011 server, which has been running fine for years, however since I have updated the client pc's to windows 10 anniversary edition I am constantly getting a services not running error on clients, having checked the services, all are in the correct state, I have tried restarting some of the obvious ones, but with no success. if I select the fix option in the alert list for the error, it clears, but then returns after 20 mins or so. Not sure what to do next to solve this.
    • well it took a great deal of time but the repair made it possible for the cleanup to go pass the 14% strange however is that even though I told it to delete all the bad backups and merge the good ones it did not clear up any of the disk space. And adding all the good merge backup sizes together shows there should be the normal 6Tb free available. So the failed backups are gone the good backups are all merged but the disk space remains at 212 Mb. not sure how to tackle this I am going to look at it again this next weekend to see if I missed something.
  • Popular Contributors

    Nobody has received reputation this week.