Sign in to follow this  
Followers 0
ironwolf

Can't Backup Gpt Partitions?

3 posts in this topic

Just finished setting up a new server with SBS 2011 Essentials. Got four workstations hooked up, all Win 7 Business x64. Two are on a new motherboard with UEFI BIOS' on them. I had no idea that Windows was going to use GPT instead of MBR on the drives. Got both of the new workstations totally done and when I tried to make the backups, they fail every single time. Checked Microsoft's website and find out that the backup feature doesn't work on GPT partitions!

I presume there is not way to convert the GPT partitions to MBR without total data loss? How do I get Windows to not use GPT and use MBR on these drives? (500GB drives) I got a bad feeling that I am going to have to start totally over from scratch. Or might I be able to make say an Acronis image of the workstations, re-format the hard drive using MBR and then restoring the image?

I could bash my head against the wall right about now. Wished I knew about this issue before hand or wished MS would fix this!

Share this post


Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

When booting from the Windows installation media from a UEFI motherboard, you typically have two options for optical media: Port#: Optical drive and UEFI: Port#: Optical drive.

Choosing the UEFI option (or if it defaults to it), will usually tell the UEFI to launch a shell to find the UEFI boot loader from the Windows install media, rather than the regular bootloader.

Having said that, there's no known way that I'm aware of to convert the disk back to MBR without data loss...using only Microsoft's available tools. There may be third-party software that can, but I don't know of one in particular.

Share this post


Link to post
Share on other sites

I don't think that using Acronis to image and reapply would work. In fact, I think you'd be stuck with GPT still.

Tools Like EaseUS Partition Manager may work. I use it all the time, but I haven't messed with GPT (in part *because* GPT backup isn't supported)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • By dwswager
      I have Windows Home Server 2011.  I wish to connect and external USB Samsung T3 SSD to it and have the server backup just a single server folder to the external drive on a scheduled basis.  I have found some guides, but based on the description and images in the directions, it does not at all match the WHS  2011 interface.  WHS 2011 is green on my system and has been since installation.  What all the directions show is blue.
      The link below has instructions, but does not match my server dashboard as shown below.
      How To Geek guide to backing up folders to an external drive.
       

    • By britgeezer
      I have 3 PC's  (2 W10 Pro and 1 W7) and a server running WHS 2011.
      All was well until I updated this PC to new W10 Pro install using an ASUS  Z07-Pro Gamer MB, all other components are the same.
      I had little trouble to install connector and dashboard started up and allowed this PC  to be added as a new user and it shows me as active under user.
      However, when I go to "computers and backup" this PC does not show up in the list of PC's that can be selected.
      I have tried uninstalling and reinstalling the connector several times, made sure I have no W10 updates pending, restarted the server all to no avail.
      If I try to run backup from Launchpad I get the message "backup is not setup for this computer".
      This has to be a simple error but its got me stumped - help please.
       
       
       
       
    • By markga
      Hi there guys, I am having a problem restoring a backup from Windows Home Server 2011 to a Windows 10 X64 Pro Client, the dashboard upon trying to restore the client says an unknown network error has occured, but this is misleading the Server is still on the network in fact shared folders are still available.
      What i have noticed is that when this occurs if i check in the dashboard all my backups are saying Backup Status unknown.  To add to the mix I am running drive bender so the drives are all basically pooled as d:\.
      Drive bender is heavilly accessing the pool and validating files, I have sent a ticket off to the makers of Drive Bender but I am awaiting their response.
      I have just tried to restore the System Reserved 350MB partition which worked just fine, it just seems to get bogged down when I am trying to restore my 128GB SSD.
       
      Any ideas guys?
       
      Thanks
       
       
    • By Sideburns
      In order to complete an application update  on our server,  I needed to pause / postpone the scheduled backup,  but I couldn't find a way to do this without disabling the server backup (I know I could have waited for the backup to start and then pause it,  but that is not very convenient) .  I expected that I could enable backup again with the same settings as before,  but when I try enabling backup,  it seems like I have to start from scratch.  Is there really no way to restore previous backup settings?? 
    • By JR15
      Yes, I am still running an HP MediaSmart Home Server v1.  I recently upgraded my laptop to Windows 10 Home and my PC to Windows 10 Pro.  The laptop (win10 Home) backs up just fine.  The desktop (win10Pro) will not.  I can get to the file shares and see old backups, but cannot start a new backup nor can I configure backups on that machine.  Sometimes I get a pop-up on the desktop saying the backup is starting and then a few seconds later, another pop-up saying the backup failed because the PC rebooted in the middle.
      Both machines were in-place updgrades through MS.
      Any ideas?


Upgrade to a WGS Supporter Account to remove this ad.



  • Posts

    • I had no problem with Windows 10.  However, I just completed the anniversary update and now the "Connector" won't run to conclusion.  It backs itself out and reports an unspecified error.
    • Apologies if I'm being stupid, but I'm having great trouble understanding how Lightsout backup and the Server Essentials 2012 backup work together (or fight with each other). I find the Lightsout documentation on this very unclear, and various threads have left me no wiser. I'd appreciate some help! Here's the setup: Lightsout is running nicely on the server. Before backups were set up, I established that the server hibernated when the clients were switched off. The server woke up when a client was powered up. (This behaviour broke when backups were set up.) The server is Essentials 2012, with a number of client laptops: a mix of Windows 7, 8 & 10. The Essentials backup window is 22:00 - 07:00. No backup settings are currently made in Lightsout. Here's what I'd like to achieve: At the end of the working day all the clients are put to sleep or hibernate (or switched off completely, I don't care which). Ten minutes after that, Lightsout hibernates the server. Sometime during the night (22:00 - 07:00) the server wakes up, then wakes up the various clients in turn, backs them up, and puts them back to sleep / hibernate / shutdown (I don't care which). Here's what actually happens (when I look at the uptime chart the next morning): At the end of the day (about 17:15) the clients are put to sleep / hibernate. (I tell the team not to shut down their client laptops because I assume the server can't wake a completely shut down client - is that correct?) The server does not hibernate. Approximately 90 minutes after the clients were put to sleep / hibernate, they all wake up simultaneously (around 18:45, but I don't know why this happens). The clients then stay awake all night. Later, from 22:00, some of the backups take place (but not all of them). The backups are spread wide apart in the 22:00 - 07:00 window with lots of time when nothing is going on at all. The clients do not go back to sleep / hibernate after their backups. ...can anyone suggest what combination of settings I should be using to get the desired behaviour? Here are the sort of things that are confusing me, but I can't find definitive answers (and each experiment I do takes 24 hours to give any results!): I know I can specify clients' individual backup times in Lightsout, but I don't know how long a client's backup will take, so I could have backups overlapping each other and causing a traffic jam. Should I worry about this? If I set Lightsout backups, what do I set for the Essentails backup window? What if it's not long enough to get all the backups done? If I make settings in the Lightsout backup dialog do I have to complete everything in that dialog box? Does this make the Essentials 2012 backup settings redundant? What about the Essentials 22:00 - 07:00 backup window, does that matter any more? I tried setting client backup times in Lightsout with an end action of 'sleep'. The backups didn't happen at all and clients all spontaneously went to sleep in the middle of the working day (the server / clients clocks all match, I checked). Can Lightsout wake up a client laptop that is completely shut down? Thanks for reading this long post and sorry if these seem like stupid questions. I already have WHS2011 / Lightsout running perfectly on another setup (where my backups take place during the day), but nocturnal backups are a new level of complexity for me!
    • Christopher wrote:  << And to clarify, if you want multiple backup drives to be cycled offsite, you MUST connect all of them at the same time when you set up the backups. >> I'm not clear about this. To the best of my recollection, I never connected both of my backup drives to the server at the same time,  For test purposes, I just initiated a recovery (using the WHS Installation Disk) with each of them hooked up.  The one that has been offsite and the one that backed up last night were both found by the "Repair an existing installation" procedure.  Perhaps I'm misreading your clarification.
    • Please check if task scheduler is still working. If not use this tool here https://repairtasks.codeplex.com/ If that does not help you may try to reinstall WHS Connector.
    • My WHS v1 (home build) starting misbehaving and finally needed a new system disk.
      After lots of threads, trial and errors, AF and non-AF drives, and lack of the Server Reinstallation choice it has finally progressed.
      Weeks of frustration. My recent attempts proceeded well but all ended up without the rebuilding of the Storage Pool (6 drives).
      The drives are detected and show up as "not added" in Server Storage and as "non managed" in Disk Management.
      There is no C:\fs on the SYS volume.
      It appears that the RebuildPrimary stage of the reinstallation, mentioned by some posters, was not successful. Has anyone found a way to force the rebuilding of the Storage Pool on reinstallation?
      I have tried X: Files v1.5.5 and the original Microsoft Disk with the same outcome. [My next step will be to migrate the "shares" and "folders" manually - it would have be quicker to have done this initially.]
       
  • Popular Contributors