• Announcements

    • Terry (WGS)

      WGS Forums Will Close on January 31st 2017   01/18/17

      Hi everyone, We're coming up to We Got Served's ten year anniversary and I've been taking a good look at the site to work through some plans for the future. I wanted to give you all a couple of weeks notice that I'll be closing WGS Forums at the end of this month.  As you'll be aware, the forums were opened to support Windows Home Server users and have done so brilliantly, thanks to everyone's participation. However, with each day that passes, there are fewer and fewer WHS deployments out there, meaning that forum registrations and traffic has now dwindled. I've tried a few times over the years to test some forums on related or adjacent topics, however, they simply haven't caught on. It's clear that these were always going to be predominately Windows Home Server forums and, with the passing of that platform, they've served their purpose well. So, please take some time to archive anything you need over the next two weeks. Access to the forums will end on Jan 31st 2017. Many, many thanks once again for your participation and support here. It's been a great community! Very best wishes Terry

Installing To Drive Smaller Than 160Gb

4 posts in this topic

I know this has been covered a few times already, but for folks who are searching this for the first time:

1. If you want to install WHS2011 to a drive smaller than 160gb - skip the cfg.ini route with a USB drive and simply install as normal - when you get to the first screen that should say Disk 0 (and only this screen) hit Shift F10.

2. That will pull up a cmd prompt window.

3. Type notepad

4. Navigate to the SKU directory

5. Tab down to All Files (not just .txt)

6. Open up the .def file within that directory (you'll see the min reqs for WHS2011 install)

7. Change the Hard drive requirements to whatever you're installing to (i.e. 50 if you're using a 60gb SSD)

8. Hit Save As and ensure you save it over the .def file (it will default to a .txt version which is useless) You'll know you did it right if it prompts you to overwrite the file.

9. Once you do that exit notepad - will bring you back to the command prompt

10. Then type wpshell.exe (not sure what this does exactly...might be able to skip this step

11. Now, proceed to install as normal and it will go right to setup.

*****No need to worry about USB drives and cfg.ini files and popping it out before reboot, etc. Seriously, this would have saved me two days of work had I known this. So I share it now.

2 people like this

Share this post

Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

I had a bummer of a time setting up WHS2011 on my Samsung 120 Gig SDD with AMD southbridge; I was having all sorts of issues with getting a CFG.ini file to work properly. 


This method worked on the first try with little effort.


For those who are having trouble with the Cfg.ini file route, this will work!

1 person likes this

Share this post

Link to post
Share on other sites

IMO the cfg.ini is still a much faster method with zero issues for me. I created my whs2011 usb flash drive, put the cfg.ini file on the root of the flash drive. Started the computer, pointed the boot process to the flash drive and a few minutes later WHS2011 was installed without asking me a single question. This was done on a nForce 650i Ultra motherboard with a Intel Q6600 cpu and a Vertex 2 60GB SSD. Could not have been any easier or faster for me.


Very surprised how well WHS2011 runs and how much easier it was over FreeNAS, for me anyway. Thanks

1 person likes this

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By cocksy_boy
      Hi All,
      I'm doing some testing on mirroring before I copy data to a new VM WHS 2011 I have built. Essentially, I'm checking out how I would be notified and recover from a failed disk in a mirrored set.
      So I created 2 vhdx's of the same size, and created a mirrored set in disk management - all goes well. I added a couple of files and check it was all working OK and it was. For my test I removed one of the vhdx's and this came up in disk management immediately (the mirror went red), which was great. However, this was when i identified my first issue: there doesn't appear to be any way for the system to notify me that one of the disks has failed, which is far from ideal.
      Question 1: Is there any way for the WHS 2011 to notify me / the admin / users that one of the mirrored disks has failed?
      My next step was to try and replace the drive check that the mirror would still be there (to simulate a temporarily failed disk), but when i reattached the vhdx the system did not recognise it as the original half of the mirror.
      Question 2: Can WHS 2011 recognise that the disk is part of the previous mirror and carry on?
      Either way the third part of the test is to replace the fully failed disk with a new one and ensure WHS 2011 can recreate the original mirror. But when adding a new disk, I can't see how to rebuild the mirrored set.
      Question 3: Please can some explain how to rebuild the mirror with a new disk and one of the original disks?
    • By andynas
      I've been having some issues recently with my N40L Microserver following a couple of bad sectors being found on the boot drive.
      After running check disk and having that mark the bad sectors out of action, I was finally able to use the Windows Server Backup tool in WHS 2011 to create a bare metal restore image and save it to a second physical drive in the box, around 40GB. 
      I don't have a DVD drive in the server so I made an ISO of the DVD Install disc, and then put that on to a bootable USB stick with the Windows USB / DVD tool from MS. I removed the damaged drive and put in a new blank drive that is twice the size of the damaged one. When I boot the installer dvd on the USB stick, it gets in to the initial screen where it asks you if you want to install a new copy or repair an installation. When I select repair, instantly I receive the error message shown in the attached pic, saying The system cannot find the specified file. 
      I get no options other than pressing the OK button and it then reboots the server. I remember having issues originally installing it from a USB drive and trying to install on an 80GB SSD - I gave up after a few hours and went with a 60GB HD partition. The install runs now if I select a new installation, it's just the repair option I can't launch. 
      I double checked the USB stick was fine by creating a new VM on my Mac, and I was able to boot that from USB and select Repair without any problem. I could browse to the network share that contains the BMR image (after replacing the dodgy boot drive back in to get back to windows) and I was able to restore the image successfully. So it seems to me there are issues with the hardware I am running and setup for WHS. It's the HP Proliant Microserver N40L @ 1.5GHz with 8GB RAM, no other changes to the standard box. 
      Any ideas how to get Repair working? 
      I managed to clone the dodgy boot drive in the end with clonezilla and so far it's working perfectly with the new drive. It would be good to know I have a proper system backup of the boot drive with a bare metal restore option in the future but until I can get Repair working on the installer dvd this isn't an option. Any suggestions greatly appreciated! 

    • By PositiveCynic
      Running WHS 2011 on a N54L, it has 2TB, 6TB, 4TB, and 5 TB drives. I have two older 4 bay Mediasonic ProBox enclosures USB enclosures for a total of 8 bays. They have 2TB drives for 7 bays and the 8th bay has a 4TB hard drive that was partitioned into two 2TB drives. I am also running StableBit. 
      I am adding an 8 bay mediasonic enclosure and I wanted to do it through estata. I am having the problem where it is only recognizing one hard drive in eSATA. No port multipler function. I briefly tried USB and I also could get only one hard drive to show up.
      I am finding older directions to flash the bios for microservers before the N54L but nothing more recent. Do I have to flash the BIOS to get eSATA to work with the 8 bay enclosure. Or would it be better to get a PCIe card for eSATA. If so, what PCIe card for eSATA or USB 3 has people gotten to work with the N54L?
      The N54L is still under warranty so I have access to the downloads at Hp under the new policy. 
    • By arkhunter
      Is there a way to split the Client Computer Backups between drives if it gets too big for a single drive? 
    • By charlvaugh73
      Hello! I am looking at a low cost storage solution for my small office. I am a film maker and churn out data bt the TBs. I already have 48 TBs in my office, spread over many 1tb and 2tb  drives. Now i am running out of space and also worry about the hard drives failing.

      I essentially require storage and archiving. Performance is NOT an important criteria. Often clients require minor alterations to their videos after 1 or even 2 years, so all my files should be accessible. Perhaps i need a Cloud Storage kind of storage, my friend told me about CloudBacko Online Cloud Storage, can i trust this storage.
      Any suggestions?

Upgrade to a WGS Supporter Account to remove this ad.

  • Posts

    • I am running WSE2012 R2 and I only ever see red, yellow or green. I have never seen blue even when backing up. I can't explain what could be happening here, but maybe some feedback from other users may help us pin it down. What OS are your client PC's? Mine are all Win 10. Not sure if that may have a bearing.   
    • I made the leap from WHSv1 to WSE2012R2.  I like the new system but one thing seems to be missing.  In WHS v1, the tray icon would change colors to indicate various things blue - backing up now green - everything is healthy yellow - warnings detected (e.g. haven't backed up in a while) red - critical issues (e.g. recent backup failed) In WSE 2012 R2, however, I only get the blue and green indicators, even when there are critical errors on my home network.  For example, a server hard drive had failed for several weeks, but the connector icon in my system tray remained green.  I only discovered the issue when I happened to login to the dashboard for something else. Does anyone know if this feature has been removed in the latest WSE versions?  Or have I just mis-configured something?
    • I am building a new home server: I really want to use StableBit DrivePool and Scanner - am used to them and like the relative ease of use. Hardware = PC running Windows 7 Pro has SSD for OS and 5 additional 2TB HDDs + SansDigital Towerraid (model TR5M6G) connected by eSATA controller (pCie) with 5 2TB HDDs of varying age (2 brand new WD Red and the remaining 3 a combo of Hiatachi and Seagate of varying age - all test out fine for now). Towerraid is currently configured as JBOD, so I can't really see individual drives, and neither does StableBit drive pool - so I get a pool consisting 5 1.82 TB drives (the ones on the PC) and 1 giant 9.1TB drive. I have about 10 TB of data ready to go into this new build.  Will be adding more over time.  Not sure when but certain I'll have HDDs go bad on me, of course. My question(s): 1)  Is there a RAID configuration that will let StableBit do its thing watching individual drives and letting me identify sick drives that need to be removed/replaced?                           2)  If I decide to give up the RAID and just let DrivePool handle duplication, how do I configure the SansDig?                           3)  Am I just getting it all wrong from the get-go? Would appreciate any advice - thanks   
    • I have almost 10 TB in the storage pool so I was not surprised when my first server backup took a very long time (22 hrs.).  Lately the incremental server backups have been fast (15 - 18 min.)  Two days ago the server apparently initiated a full backup that failed twice but completed successfully this morning after about 23 hours.  An hour later the regular daily backup is back to a normal incremental backup times (18 min.) So why did the previous backup take so long, as long as a full backup would take? Does the server occasionally make a fresh start with a full backup to reduce the time a full incremental recovery takes?  (fewer increments, less processing time) I don't see a setting in the server backup options for specifying a number of increments between full backups, for example.    
    • I just posted a similar question elsewhere.  By Shadow Copies are you referring to the Windows 10 File History backups that periodically use shadow copy to backup open files? I too discovered that a huge amount of backup space was consumed by File History backups, no doubt because I was moving some large Blu-Ray files around.  That I fixed by moving the temporary and final file folders to the server, where they are backed up as part of the daily server backup.  That too, of course, uses Shadow Copies but that is another story. Has anyone done the math?  What is the equivalence .. or lack thereof ... between the traditional WS2012r2 (WHS v1 et al.) daily incremental backup :: and a Win7 System Image backup + File History backups? Restore time comparison? Which do you feel is best?
  • Popular Contributors