Win8 Server And Robocopy Logs

2 posts in this topic

I "upgraded" from WHS 211 to Windows 8 and now have troubles with Robocopy. Researching online shows that older versions of Robocopy tend to copy unchanged files while using the /MIR switch. The new version  of Robocopy (6.2) bundled with Windows 8 seems to work, but the log file is horribly messed up.  Anyone have an idea?


command lines:


robocopy.exe "D:\test" "F:\Backups\test" /MIR "/log:test.txt" /V
"old robocopy.exe" "D:\test" "F:\Backups\test2" /MIR "/log:test2.txt" /V

Examples of the log files:

Older version:


   ROBOCOPY     ::     Robust File Copy for Windows     ::     Version XP010
  Started : Thu Jan 17 08:51:47 2013
   Source : D:\test\
     Dest : F:\Backups\test2\
    Files : *.*
  Options : *.* /V /S /E /COPY:DAT /PURGE /MIR /R:1000000 /W:30 
 New Dir          3 D:\test\
   New File    488425 Picture 008.JPG
   New File     31789 Picture 050.JPG
   New File    613894 Picture 141.JPG
                Total    Copied   Skipped  Mismatch    FAILED    Extras
     Dirs :         1         1         0         0         0         0
    Files :         3         3         0         0         0         0
    Bytes :    1.08 m    1.08 m         0         0         0         0
    Times :   0:00:00   0:00:00                       0:00:00   0:00:00
    Speed :            10310072 Bytes/sec.
    Speed :             589.947 MegaBytes/min.
    Ended : Thu Jan 17 08:51:47 2013
New version 6.2:


   *.* /V /S /E /DCOPY:DA /COPY:DAT /PURGE /MIR /R:1000000 /W:30 D:\test\Picture 008.JPGPicture 050.JPGPicture 141.JPG                              1      1 0 0 0 0       3      3 0 0 0 0  1.08 m 1.08 m 0 0 0 0                                           

Share this post

Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

I have built a w 8 system with whs 2011 running in a virtual machine. I used Robocopy to move files from the server video directory to the w8 video folder so I could play the files in meda center in the w8 machine. But after the Robocopy runs the file permissions changed in the source server folder. I finally gave up on the move and just went with the copy only and the source folders permissions didn't change. I don't have a solution for you, but I have something going on here with Robocopy I don't understand either.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By mediadogg
      [font='times new roman']The purpose of this program is to provide, in one place, a set of tools for helping to keep track of the risks associated with data backup strategies. [/font]

      [size=4][font='times new roman']An ad-hoc risk assessment is determined, based primarily on the number and location of copies of your data. Tools are provided for capturing and saving the server location of your data folders and automating the running of scripts that make backup copies of the data.[/font][/size]
      [size=4][font='times new roman']Other tools are provided for burning copies of data on optical media, and for keeping track (audit) of when copies have been made and where they are located. Extensive Help is built-in, including a detailed “Hit and Tips” section where the author’s shares aspects of his many years of experience in handling and protecting data in the home environment. [/font]

      [font='times new roman']DataRisk makes it easy to collect and maintain a list of all your data sources and shared folders in a spreadsheet format. Once collected, it is possible to use the spreadsheet to keep track of backup operations and to selected various folders to be used in automated script operations. It is possible to use you own custom scripts, or to use pre-defined templates for Microsoft RoboCopy, Microsoft RichTools and the third-party program Beyond Compare ™, the author’s favorite data copy program. (Disclaimer: the author has no interest or investment in Beyond Compare – just deep respect and admiration for its capabilities and quality). [/font]
      [font='times new roman']DataRisk computes a subjective assessment of the risk of losing a data folder based on the number of online, offline, optical and off-site copies:[/font][/size][list]
      [*][size=4][color=#FF0000][font='times new roman']High Risk (red color):[/font][/color][font='times new roman'] only one online copy of the data.[/font][/size]
      [*][size=4][color=#ffcc00][font='times new roman']Moderate Risk (yellow):[/font][/color][font='times new roman'] more than one copy online, but no off-site or optical copy.[/font][/size]
      [*][size=4][color=#00b050][font='times new roman']Low Risk, Lower Risk (light green):[/font][/color][font='times new roman'] off-line and /or optical copies, but no off-site copy.[/font][/size]
      [*][size=4][color=#00863d][font='times new roman']Lowest Risk (dark green):[/font][/color][font='times new roman'] More than one online, at least one offline / optical and at least one off-site copy.[/font][/size]
      [size=4]A Basic (free) version is available [url="http://www.mediadogg.com/datarisk.html"]here[/url], and a Pro (fee) version is available [url="http://www.mediadogg.com/shopping/index.php?act=viewProd&productId=9"]here[/url].

      A brief [url="http://www.mediadogg.com/shopping/downloads/drUG.pdf"]User Guide[/url] is available, and more detailed usage information is provided in the buil-in product Help.[/size]
    • By WScottCross
      I created a script a long time ago (back when I had WHS v1) to manage archiving my recorded TV. It moves all recordings older than 5 days to a server shared folder. I started having issues after upgrading to WHS 2011 and I thought it was because I also set up a RAID6 with a dedicated controller. It turns out that it appears to have something to do with running robocopy in a scheduled script. I can drag the files over in Windows Explorer and not have any issues at all. If I run the script, it works for a portion of the files and then the server completely stops responding to the network and requires a hard reset to recover. I'm starting to wonder if the motherboard (ASUS P8P67 Pro) NIC driver is the root cause. The board uses an Intel 82579V controller, which is officially not supported under server OS, but I was able to get it working with the 82579LM driver. I just dont understand why it works fine through Windows Explorer but not as a script!

      I ordered a different NIC to try, but wanted to see if anyone else has run into similar problems?

Upgrade to a WGS Supporter Account to remove this ad.

  • Posts

    • So I currently have Windows Server 2012 Essentials (running in a Hyper-V VM) and am thinking about migrating to a Windows 10 server. I have 12 disks or so on the server all configured via Storage spaces. Can I simply connect these disks up to a Windows 10 install and have all the files appear? From what I have read the storage space info is all on the disks and it should work, but has anyone here actually tried it and succeeded. I have 10+ TB of data and the easiest way to get it to the new server would be to just connect the disks up.   Thanks, -Bill
    • Did you try CC cleaner or a disk clean up program? It seems to me that old files merged or not are still existing, do you have external storage that you could export the known good files to while you reformat and clean the 6TB?
    • Hello Is it possible to clone an external HDD containing the server backup to another external HDD? The external HDD doesn't have a drive letter, so how can I clone the drive?  I have two external drives in a Dual Dockingstation (2 drives), which has a button to clone from A to B, but I don't trust that solution too much..
    • I have a whs 2011 server, which has been running fine for years, however since I have updated the client pc's to windows 10 anniversary edition I am constantly getting a services not running error on clients, having checked the services, all are in the correct state, I have tried restarting some of the obvious ones, but with no success. if I select the fix option in the alert list for the error, it clears, but then returns after 20 mins or so. Not sure what to do next to solve this.
    • well it took a great deal of time but the repair made it possible for the cleanup to go pass the 14% strange however is that even though I told it to delete all the bad backups and merge the good ones it did not clear up any of the disk space. And adding all the good merge backup sizes together shows there should be the normal 6Tb free available. So the failed backups are gone the good backups are all merged but the disk space remains at 212 Mb. not sure how to tackle this I am going to look at it again this next weekend to see if I missed something.
  • Popular Contributors

    Nobody has received reputation this week.