PS3 Media Server

59 posts in this topic

Posted · Report post

Hi

Have been using the below software to stream content from my HP to my PS3 and it really is good

http://ps3mediaserver.blogspot.com/

Problem is that to enable the PS3 to see the server, you have to login via remote desktop once to allow it to complete the boot sequence and for the Java based streamer to load. When using WMP11, this wasn't an issue as PS3 picked up the sever without having to login via remote desktop. Does anyone know if there is a workaround or has anyone managed to get this loading without logging in first?

thanks

Share this post


Link to post
Share on other sites

Upgrade to a WGS Supporter Account to remove this ad.

Posted · Report post

Hi

Have been using the below software to stream content from my HP to my PS3 and it really is good

http://ps3mediaserver.blogspot.com/

Problem is that to enable the PS3 to see the server, you have to login via remote desktop once to allow it to complete the boot sequence and for the Java based streamer to load. When using WMP11, this wasn't an issue as PS3 picked up the sever without having to login via remote desktop. Does anyone know if there is a workaround or has anyone managed to get this loading without logging in first?

thanks

Check out the discussion already-

http://forum.wegotserved.com/index.php?showtopic=5200

PLEASE CLOSE TOPIC

Share this post


Link to post
Share on other sites

Posted · Report post

PLEASE CLOSE TOPIC

That topic is titled "Stream .mkv to PS3" - this one is on the wider subject of PS3 Media Server - we will let them both run their course.

Please use the other topic for .mkv specific discussion

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

Have been using the below software to stream content from my HP to my PS3 and it really is good

http://ps3mediaserver.blogspot.com/

Problem is that to enable the PS3 to see the server, you have to login via remote desktop once to allow it to complete the boot sequence and for the Java based streamer to load. When using WMP11, this wasn't an issue as PS3 picked up the sever without having to login via remote desktop. Does anyone know if there is a workaround or has anyone managed to get this loading without logging in first?

thanks

When you're logged into your WHS via remote desktop, fire up the GUI for PS3-Media-Server, and under the 'General Configuration' tab, click the option to 'Install as a Windows Service'. After clicking this it will tell you that you need to visit Start > Control Panel > Administrative Tools > Services to 'manually' change the Startup Type from Manual to Automatic for the PS3 Media Server service. Et voila! Worked for me :-)

Share this post


Link to post
Share on other sites

Posted · Report post

Note the latest release of PS3 Media Server (1.02) has a 'run as a service' option. I tried this with no sucecss. Have resorted back to 'AnyServiceInstaller' which works well. Note you can delete services by running 'sc delete <service name>'. If the <service name> has spaces then put it in quotes.

1.02 also installs PS3 Media Server in C:\Program Files which makes adminsitartion a lot easier.

Note also that PS3 Media Server successfully streams .mt2s content with speeds up to 100mb/sec (assuming you have a Gb LAN). It is software like this that really plays to the strengths of WHS.

Share this post


Link to post
Share on other sites

Posted · Report post

I've found that with the latest update 1.02.1 the install as service option does install it as a service but the PS3 can't see the server.

I ended up using the AnyServiceInstaller on it and it worked fine.

Share this post


Link to post
Share on other sites

Posted · Report post

Just to let everyone know, there is a new version (v1.03) available now: http://ps3mediaserver.blogspot.com/

There is also a forum that has just been established. I just discovered ps3mediaserver and am going to give it a whirl.

Liste

Share this post


Link to post
Share on other sites

Posted · Report post

Works ok so far, it shuttered alot when I only had 1GB of RAM in the server. I upgraded the server to 3GB of RAM and it now seems to screem along :)

My only issue now is getting dual audio files to work, or work out how to strip out the english audio track and mark it as primary

Share this post


Link to post
Share on other sites

Posted · Report post

Working for me too......with virtually no configuration.

Share this post


Link to post
Share on other sites

Posted · Report post

PS3 Media Server 1.04 was released on 4 Feb 09.

On a separate note has anyone found a sure fire way of getting all XViDs to play without any transcoding? I normally use TSMuxer as the preferred streaming engine and the majority of things work fine but every now and then a file won't play. I then have to use Mencoder and play an MPEG2 transcoded version of the file.

As an example I can play the following file using TSMuxer, reported by Media Info as;

Container and general information

AVI: 350MiB, 41mn 7s

1 video stream: MPEG-4 Visual (XviD)

1 audio stream: Mpeg Audio (MP3)

Writing application: transcode-1.0 5rc4

First video stream

1006 Kbps, 624*352 (16/9), at 23.976 fps. MPEG-4 Visual (XviD) (Packed Bitstream) (Streaming Video@L1) (BVOP)

First audio stream

172 Kbps (16 Kbps), 48.0KHz, 2 channels, MPEG Audio (MP3) (Version 1) (Layer 3) (Joint Stereo)

but get a 'data unsupported' error message when I try to play the following file using TSMuxer, reported by Media Info as;

Container and general information

AVI: 349MiB, 40mn 55s

1 video stream: MPEG-4 Visual (XviD)

1 audio stream: Mpeg Audio (MP3)

Writing application: MEncoder dev-SVN-r26059-4.1.2

Writing library: Mplayer

First video stream

1055 Kbps, 624*352 (16/9), at 23.976 fps. MPEG-4 Visual (XviD) (Packed Bitstream) (Streaming Video@L1) (BVOP)

First audio stream

124 Kbps (16 Kbps), 48.0KHz, 2 channels, MPEG Audio (MP3) (Version 1) (Layer 3) (Joint Stereo)

Not a major problem as I can watch my XViD files - albeit transcoded to MPEG-2, I am just hoping someone can give some pointers of how to improve my setup? Currently have my self build WHS connected via a wired gigabit LAN to my PS3.

Cheers,

Yak.

Share this post


Link to post
Share on other sites

Posted · Report post

Not sure what I'm missing here .

My PS3 can see my HPWHS via Windows Media Connect; dont recall doing any special configuration.

Is there additional functionality I'm not understanding in this thread?

IMHO, I dont think that the PS3 is a functional media player especially for those of us with large libraries.

It is a rather clueless application with little browsing or other usability goodies.

I use Squeezebox Duet which is a good solution with a lot of functionality

Share this post


Link to post
Share on other sites

Posted · Report post

HI RichNY - are you saying that you can play your XviDs on your PS3 streamed from your WHS through media connect without any problems?

As for missing out on anything, I went for PS3mediaserver for the fact that it could stream mkv files to the PS3 in a format that it could play by altering the container format i.e. no transcoding required. See here for more info.

Share this post


Link to post
Share on other sites

Posted · Report post

HI RichNY - are you saying that you can play your XviDs on your PS3 streamed from your WHS through media connect without any problems?

As for missing out on anything, I went for PS3mediaserver for the fact that it could stream mkv files to the PS3 in a format that it could play by altering the container format i.e. no transcoding required. See here for more info.

No - cant do that. All that I do is stream mp* and wm* music and look at photos

So guess I dont need PS3mediaserver.....

Share this post


Link to post
Share on other sites

Posted · Report post

PS3Media Server 1.10 has been released.

Info about the update from the wesbite;

"Some time has passed since the last version, so here's a major one ! Hopefully, it offers some interesting features to all ps3 owners running on Windows or Linux, like the DTS streaming support (no need anymore to encode in AC3 or PCM if you have a DTS compatible receiver), an improved Mencoder engine with automatic decision between muxing (aka no video encoding) and full video transcoding. About the DTS feature, make sure to read carefully the message box who will appear if you enable this option. Also, the automatic muxing option is enabled by default, to offer the best video quality when this is possible (if the video track is compatible and no subtitles are involved). Keep in mind that it's a new feature, so if anything bad happens, you can disable it in the mencoder configuration panel (or in the #Video Settings# virtual menu on XMB). There's other things to try, check the changelog !"

Share this post


Link to post
Share on other sites

Posted · Report post

To get the PS3 Media Server to run as a service consistently I have found I needed to do the following (Have also posted this on the PS3 Media Server site):

You need to run the Wrapper.exe as a standalone application first. The windows firewall then creates two rules (UDP and TCP) to allow the wrapper application to use the network. Personally the rule is a little too open, however you can lock it down to only the ports required if you are more security conscious.

Once the wrapper has been run successfully as a standalone application (firewall rules added by the system) it can now be run as a service and works well.

Works for me anyway. Note the Wrapper when run standalone opens a command windows. The wrapper can be terminated by pressing Ctrl-C which does a clean shutdown of the program.

Share this post


Link to post
Share on other sites

Posted · Report post

To get the PS3 Media Server to run as a service consistently I have found I needed to do the following.........

Hi Lenno,

I also had issues using the tick box in the configuration pages for PS3mediaserver to get it to run as a service. However, I used the AnyService Installer route and have had no problems.

Share this post


Link to post
Share on other sites

Posted · Report post

On a abstracted agenda has anyone begin a abiding blaze way of accepting all XViDs to play after any transcoding? I commonly use TSMuxer as the adopted alive engine and the majority of things plan accomplished but every now and again a book will not play. I again accept to use Mencoder and play an MPEG2 transcoded adaptation of the file.

_________________

Predictive dialer

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Question about this program. Will it stream a ripped movie (a-la DVDFab) in its entirety and not just vobs like I am currently experiencing now? I want to watch the whole thing like I was watching a disc in the PS3 but across the network via my WHS. I must be missing something after the ripping step in order to achieve this or it's something else.

Thanks in advance, I just started getting back to looking into streaming videos (DVD and eventually Blu-Ray rips that don't come with the digital copy if I can figure that one out yet...).

Mike

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Mike,

As for having an experience like popping in a DVD with a menu, I don't know if that is possible. However PMS is able to take the DVD Folder structure and play it without needing to convert it to a video file.

Share this post


Link to post
Share on other sites

Posted · Report post

I copy all my DVD movies, for archival purposes to disc, with 1Click DVD Copy, but then I prefer to use DVD Shrink to convert the movie to a single .vob file, and just rename that file to the name of the movie. I don't want or need subtitles.

For my Blu-Rays, I use BD Rebuilder (beta) to convert the movie down to fit onto a DL DVD (movie only) then rename the resulting .m2ts file to the name of the movie.

These both play very well on the PS3 and don't require any transcoding.

You won't get any menus or extras...just the movie. I suppose you do each bonus feature or titleset the same way, but I doubt it would be worth it. I don't think its even possible with Blu-Ray, though.

Share this post


Link to post
Share on other sites

Posted · Report post

As for your Blu-Ray ripping, what is the resulting bitrate? I am guessing the file is in H.264... What kind of processor do you have and how long does it take to rip a Blu-Ray?

As for the DVDs, have you looked at converting the mpeg2 to H.264?

Share this post


Link to post
Share on other sites

Posted · Report post

As for your Blu-Ray ripping, what is the resulting bitrate? I am guessing the file is in H.264... What kind of processor do you have and how long does it take to rip a Blu-Ray?

As for the DVDs, have you looked at converting the mpeg2 to H.264?

There are several different setting use can use with BD Rebuilder, so the bitrate would be dependent on those settings. I haven't tried a straight rip from AnyDVD-HD, because I don't want to give up that much drive space.

You'll have to talk to someone smarter than me for the technical stuff like bitrates. :-)

On my Intel Q960 4gb PC, It takes about 25 minutes or so to rip an average 40gb Blu-Ray to the HDD with AnyDVD-HD, and then anywhere from 2hrs to 8hrs to convert it down to down to fit on a BD-R 25gb or DL DVD size, depending on the quality level you choose. You can get all the info you need here: http://forum.doom9.org/forumdisplay.php?f=75

I've never even considered converting a DVD mpeg2 to H.264. What's the benefit?

Share this post


Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...



Upgrade to a WGS Supporter Account to remove this ad.



  • Latest Posts

    • Windows 10 Server Not Suspend
      By Lamplugh · Posted
      Apologies for the delay in responding but I have been trying out a number of options all to no avail. As Andrew suggested I have disabled Wake on Pattern Match, (It was previously enabled.) The Power Power Management options were already ticked, so I have tried unticking them all waiting 24 hours and then reticking. Wake on Magic Packet is currently enabled, I don't know if I should change that. I don't seem to have the Shutdown Wake on Lan option but I do have WOL & Shutdown Link Speed which is set to 10 Mbs First. I still feel it is some W10 feature as the new system seems dead keen on talking to Microsoft at every opportunity. I have obviously tried to switch as many of these off as I know about. Any suggestion welcome as I don't really want my server on effectively 24/7.  
    • Temp Files Created By Server Backup
      By Dave Marchant (WGS) · Posted
      It sort of makes sense as the oldest tmp file corresponds to the oldest backup. I agree that it is not good design. I don't fancy a BSOD just at the moment as about to go away on holiday so need to have the server working reliably while I am away or I get no email  Could be one for the MVP's to feed back into Microsoft for a comment. 
    • Temp Files Created By Server Backup
      By glorp · Posted
      Thank you for confirming that Dave! I don't have the full gui installed so I couldn't do a Disk Cleanup on mine. I wondered if that would work to get rid of them. Guess not. I suspect they may be some kind of mount point for the vhd that is created right at the beginning of backup and deleting them causes havoc later when Server Backup tries to do incremental backups using the old mount point. My backups "exist" forever since they are on 1TB and in no danger of running out of space. It occurred to me that maybe they get deleted when a backup gets removed. In any case it's a pretty piss poor design to leave critical ".tmp" files in Windows\Temp if you ask me. If you really want to test things at your end, delete them In any case at least I know what has been causing the random BSODs I get every few months since I installed WSE2012 and what to do not to get them.  
    • Moving from V1 to Essentials
      By Dave Marchant (WGS) · Posted
      Sorry, the backups are not compatible with WHS 2011 or any of the Server Essentials variants. There is no easy workaround either.  You don't give any indication in the spec of the V1 box so difficult to say whether Essentials will run on it. I beleive the limitation may possibly be RAM if you are thinking of one of the original HP Home Servers.    
    • Moving from V1 to Essentials
      By fasttimes · Posted
      So I have a new WSS box arriving tomorrow.  Are the backups made with V1 compatible with Essentials?  Is it possible to migrate them to the new box?  Any suggestions on what to do with the V1 box?  It it possible to load Essentials on it (legality aside)?
  • Recently Browsing

    No registered users viewing this page.